在CentOS 6.x安装php 5.4 1


屁民瑞威最近需要安装一个php的开源系统,该系统最低要求的php版本是5.3.10,而CentOS 6.4使用的是5.3.3。那么问题来了,需要升级php版本。

1、源码安装

由于测试而已,嫌麻烦,跳过

2、第三方包

Remi & Epel Repository

参考http://www.php100.com/html/php/rumen/2013/0909/6094.html

3、SCL

严格说来,这个也算第三方包吧。

SCL:The Software Collections ( SCL ) Repository,这个是redhat为新版本软件新增的一个项目,可以理解为可以让你通过yum安装新版本软件。

目前支持的软件有(虽然文章说支持6.5以后版本,经过测试6.4也可以)

Ruby 1.9.3 (ruby193)
Python 2.7 (python27)
Python 3.3 (python33)
PHP 5.4 (php54)
Perl 5.16.3 (perl516)
Node.js 0.10 (nodejs010)
MariaDB 5.5 (mariadb55)
MySQL 5.5 (mysql55)
PostgreSQL 9.2 (postgresql92)

好了,不废话,上代码:

 

参考:

https://blog.carroarmato0.be/2014/12/23/using-php5-4-on-centos-6-6-with-scl/

http://stackoverflow.com/questions/25574434/how-to-permanent-enable-php-5-4-on-rhel-php-5-3-3-also-installed-on-the-system?answertab=active#tab-top

https://webtatic.com/packages/php55/

 

版权声明:本文《在CentOS 6.x安装php 5.4》为【屁民部落】原创/翻译文章,转载时请注明出处!
本文地址:http://pimin.net/archives/483

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

One thought on “在CentOS 6.x安装php 5.4